LNR - Operational incident at London Kings Cross – Incident details

All systems operational

Operational incident at London Kings Cross

Resolved
Major outage
Started almost 4 years agoLasted 6 minutes

Affected

Route Network

Major outage from 8:07 PM to 8:13 PM

London

Major outage from 8:07 PM to 8:13 PM

Updates
  • Resolved
    Resolved

    Services are now returning to normal following an incident earlier at London Kings Cross. Please check before you travel.

  • Monitoring
    Monitoring

    Due to an operational incident at London Kings Cross, some trains were delayed or cancelled. We’ve rectified the issue, and may be some residual delays.

  • Investigating
    Investigating

    Due to an operational incident, services may be subject to delay or cancellation from London Kings Cross. Update to follow at 21:00.